import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Job started at\\s'(\\d+\\s\\d+:\\d+:\\d+:\\d+)'\\s+orderno\\s+-\\s+'(\\w+)'\\s+runno\\s+-\\s+'(\\d+)'[\\s\\S]+?Host1\\s'([\\w.]+)'\\[([\\w-]+)\\] username '([\\w\\\\]+)' - Host2\\s'([\\w.]+)'\\[([\\w-]+?)\\] username '([\\w\\\\]+)'[\\s\\S]+?(?:(Job executed successfully)[\\s\\S]+?)?Job ended at\\s'(\\d+\\s\\d+:\\d+:\\d+:\\d+)'\\s+Elapsed time\\s\\[([\\d.]+)sec\\]\\sCPU usage\\s\\[([\\d.]+)sec]";
final String string = "Job started at '0902 23:56:00:367' orderno - '0tzh0' runno - '00064' Number of transfers - 1\n\n"
+ "Host1 'Local'[Windows-LOCAL] username 'xxx\\xxx' - Host2 'xxx.xxx.xx'[Unix-SFTP] username 'xxx'\n\n"
+ "Local host is: xxx - Windows 200x [601] Service Pack 1 build 7601 - Intel64 Family 6 Model 37 Stepping 1, GenuineIntel\n\n"
+ "********** Starting transfer #1 out of 1 *************** Transfer #1 completed successfully\n\n"
+ "Job executed successfully. exiting.\n\n"
+ "Job ended at '0902 23:56:07:138' Elapsed time [7sec] CPU usage [0.15sec]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}