using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+\s+(?:BIS|TER|RUE|\d*)\s*(?:STREET|AVENUE|BOULEVARD|PIERRE)\s+.*?)\s*(?=(?:\d+|$))";
string input = @"THIS IS 24 RUE PIERRE LAPIN 2 AVENUE DES LAPINOUS ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}