re = /(\d+\s+(?:BIS|TER|RUE|\d*)\s*(?:STREET|AVENUE|BOULEVARD|PIERRE)\s+.*?)\s*(?=(?:\d+|$))/m
str = 'THIS IS 24 RUE PIERRE LAPIN 2 AVENUE DES LAPINOUS '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end