import Foundation
let pattern = #"(\d+\s+(?:BIS|TER|RUE|\d*)\s*(?:STREET|AVENUE|BOULEVARD|PIERRE)\s+.*?)\s*(?=(?:\d+|$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"THIS IS 24 RUE PIERRE LAPIN 2 AVENUE DES LAPINOUS "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)