package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)^(table|figure)`)
var str = `Table 1. Findings. # Matches.
This header contains a table. # Does not match; 'table' is not at the beginning.
figure 1. An illustrative diagram. # Matches, thanks to the case-insensitive modifier.
TABLE 2: Limitations. # Matches, thanks to the case-insensitive modifier.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}