use strict;
my $str = 'Table 1. Findings. # Matches.
This header contains a table. # Does not match; \'table\' is not at the beginning.
figure 1. An illustrative diagram. # Matches, thanks to the case-insensitive modifier.
TABLE 2: Limitations. # Matches, thanks to the case-insensitive modifier.';
my $regex = qr/(?i)^(table|figure)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}