// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)^(table|figure)").unwrap();
let string = "Table 1. Findings. # Matches.
This header contains a table. # Does not match; 'table' is not at the beginning.
figure 1. An illustrative diagram. # Matches, thanks to the case-insensitive modifier.
TABLE 2: Limitations. # Matches, thanks to the case-insensitive modifier.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}