import Foundation
let pattern = #"(?i)^(table|figure)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Table 1. Findings. # Matches.
This header contains a table. # Does not match; 'table' is not at the beginning.
figure 1. An illustrative diagram. # Matches, thanks to the case-insensitive modifier.
TABLE 2: Limitations. # Matches, thanks to the case-insensitive modifier.
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)