package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z]{3}[p|P|c|C|h|H|f|F|a|A|t|T|b|B|l|L|j|J|g|G][A-Za-z][\d]{4}[A-Za-z]$`)
var str = `dfxpk1218r`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}