using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"chrome\D\d{0,}";
string input = @"chrome
chrome#32
chrome#2
chrome#543
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}