# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^-\n]*-[^=\n]*)-.*?(\.\w+)$"
test_str = ("Tab 3-3-z-o.pdf\n\n"
"Should be Tab 3-3.pdf\n\n"
"Tab 2-3-jk2.pdf\n\n"
"Should be: Tab 2-3.pdf\n\n"
"Tab 3-3-Yuwk-3-k-l-s.pdf\n\n"
"Should be: Tab 3-3.pdf")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.