import Foundation
let pattern = #"^([^-\n]*-[^=\n]*)-.*?(?i)(\.pdf)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Tab 3-3-z-o.pdf
Should be Tab 3-3.pdf
Tab 2-3-jk2.pdf
Should be: Tab 2-3.pdf
Tab 3-3-Yuwk-3-k-l-s.pdf
Should be: Tab 3-3.pdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)