import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\(|\\[| |-)+((,| )*(AU|JP|CA|NZ|US|KR|GB)(,| )*)+(\\)|\\]| |-|$)+";
final String string = "Antivirus, Booster & Cleaner - Android - US\n"
+ "Monster Strike Android JP\n"
+ "LINE Bubble 2 iOS (JP)\n"
+ "LINE Bubble 2 iOS ( JP , AU )\n"
+ "Monster Strike (iPhone, iPad) JP\n"
+ "Game of War Android (US AU CA JP KR GB)\n"
+ "Caesars Slots iPhone ( AU,CA, NZ,US)\n"
+ "Caesars Slots iPhone [ AU,CA, NZ,US]\n"
+ "Caesars Slots iPhone AU,CA, NZ,US\n"
+ "( ,AU) Caesars Slots iPhone\n"
+ " match";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}