package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/(?<page>(?:post_beta|breaking_post_beta|post_beta_static)(?:/.*)?)$`)
var str = `Should match:
/post_beta
/breaking_post_beta
/post_beta_static
Should not match:
/post
/breaking_post
/post.json
/breaking_post.json
/post_beta.json
/breaking_post_beta.json`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}