#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)th[^>]+l">(.*?)<\/th>.*?<td>(.*?)<\/td>.*?<a id="(.*?)""
Local $sString = "<th scope="col">1X2</th>" & @CRLF & _
" <th scope="col" class="goR">Odds</th>" & @CRLF & _
" </tr></thead>" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr class="row1">" & @CRLF & _
" <td>Fortuna Köln</td>" & @CRLF & _
" <td class="prc "><label><a id="MarketGroupListComponent25-selection-38225206.1" />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")