re = /^(.*):\/\/(.*)(:\d+)\/(.*)$/m
str = 'https://uat42.my.example.com:56/Pizza?slice=2'
subst = '\\1://\\2/\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result