// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*):\/\/(.*)(:\d+)\/(.*)$").unwrap();
let string = "https://uat42.my.example.com:56/Pizza?slice=2";
let substitution = "\\1://\\2/\\4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}