using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/?images\/(?!.*\bignore\b)[^.]*\.(?:png|jpe?g|gif|svg|tiff|other_extensions)";
string input = @"/images/image-filename-ignore.png
/images/image-filename-ignores.JPEG
/images/image-filename-notignore.PNG
/images/image-filename-ignore.GIF
/images/image-filename-ignores.JPG
images/image-filename-notignore.TIFF";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}