import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/?images\\/(?!.*\\bignore\\b)[^.]*\\.(?:png|jpe?g|gif|svg|tiff|other_extensions)";
final String string = "/images/image-filename-ignore.png\n"
+ "/images/image-filename-ignores.JPEG\n"
+ "/images/image-filename-notignore.PNG\n"
+ "/images/image-filename-ignore.GIF\n"
+ "/images/image-filename-ignores.JPG\n"
+ "images/image-filename-notignore.TIFF";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}