import Foundation
let pattern = #"(?<!\w)@\w+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
INSERT INTO Recibos (idRecibo, DataRecibo, NomeCliente, Valor, CPFCliente, EnderecoCliente, NumeroCliente, BairroCliente, Importancia, Referente, Cidade, UF, Emitente, EnderecoEmitente, NumeroEmitente, BairroEmitente, CPFEmitente, RG) VALUES (" +
"@idRecibo," +
"@dataRecibo," +
"@nomeCliente," +
"@valor," +
"@cpfCliente," +
"@endCliente," +
"@numCliente," +
"@baiCliente," +
"@importancia," +
"@referente, +" +
"@cidade," +
"@uf," +
"@emitente," +
"@endEmitente," +
"@numEmitente," +
"@baiEmitente," +
"@cpfEmitente," +
"@rg)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)