$re = '/(?:^group |\G(?!^))(\S+)(?:\s+|$)/m';
$str = 'group g1 l1 l2 l3 g2 g3.l1
group g1 g2.l1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);