using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""ABC""";
string substitution = @"""DEF""";
string input = @"BLABLUB SHSJSKSKDKDNDNDKD ABC dndjmsmdmdmdmdm ""ABC""";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}