use strict;
my $str = 'BLABLUB SHSJSKSKDKDNDNDKD ABC dndjmsmdmdmdmdm "ABC"';
my $regex = qr/"ABC"/mip;
my $subst = '"DEF"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";