const regex = /(\S)<\/[^>]*>\s*<[^>]*>(\S)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S)<\\\/[^>]*>\\s*<[^>]*>(\\S)', 'g')
const str = `<Inventory>
<Item>
<Name>Super Mario Bros</Name>
<Count>14</Count>
<Price>29,99</Price>
<Comment>-No Comment-</Comment>
<Artist>N/A</Artist>
<Publisher>Nintendo</Publisher>
<Genre>Video Games</Genre>
<Year>1985</Year>
<ProductID>001</ProductID>
</Item>
<Item>
<Name>The Legend of Zelda</Name>
<Count>12</Count>
<Price>34,99</Price>
<Comment>-No Comment-</Comment>
<Artist>N/A</Artist>
<Publisher>Nintendo</Publisher>
<Genre>Video Games</Genre>
<Year>1986</Year>
<ProductID>002</ProductID>
</Item>
</Inventory>`;
const subst = `$1","$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);