// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)mul\((\d{1,3}),(\d{1,3})\)|do\(\)|don't\(\)").unwrap();
let string = "mul(12,15)do()don't()";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}