$re = '/\D(\d)$/m';
$str = 'Paris 3
Paris 17
Marseille 5
Abainville
Aast
Marseille 15
Lyon 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);