import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = ##"""
(?<d> [0-9] [-_ –.]* ){4} # subpattern definition
(?=
\g<d>{4} (?: \g<d> (?: \g<d>{3} )? )? # allowed digit sequences
(?: \g<d>+ (*SKIP) (*F) )? # skip the substring if digits remain
)
\g<d>* (?= \g<d>{4} ) # backtrack until there're 4 digits at the end
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
valid:
12345678
123456789
123456789012
123-456789
123 45 6789
123 – 45 – 6789
invalid:
1234567
1234567890
12345678901
1234567890123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)