#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d{2}/\d{2}/\d{2,4}$"
Local $sString = "My birthday is 11/13/2018" & @CRLF & _
"Another way is to say 11/13/18" & @CRLF & _
"And the day after 11/13/2018 is 11/14/2018"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)