using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{2}/\d{2}/\d{2,4}$";
string substitution = @"";
string input = @"My birthday is 11/13/2018
Another way is to say 11/13/18
And the day after 11/13/2018 is 11/14/2018";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}