import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{2}/\\d{2}/\\d{2,4}$";
final String string = "My birthday is 11/13/2018\n"
+ "Another way is to say 11/13/18\n"
+ "And the day after 11/13/2018 is 11/14/2018";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}