const regex = new RegExp('\\d{2}/\\d{2}/\\d{2,4}$', 'gm')
const str = `My birthday is 11/13/2018
Another way is to say 11/13/18
And the day after 11/13/2018 is 11/14/2018`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);