import re
regex = re.compile(r"\d{2}/\d{2}/\d{2,4}$", flags=re.MULTILINE)
test_str = ("My birthday is 11/13/2018\n"
"Another way is to say 11/13/18\n"
"And the day after 11/13/2018 is 11/14/2018")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)