// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{2}/\d{2}/\d{2,4}$").unwrap();
let string = "My birthday is 11/13/2018
Another way is to say 11/13/18
And the day after 11/13/2018 is 11/14/2018";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}