import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?>\\V*\\n){9,}\\V*$()";
final String string = "LINE 1\n"
+ "LINE 2\n"
+ "LINE 3\n"
+ "LINE 4\n"
+ "LINE 5\n"
+ "LINE 6\n"
+ "LINE 7\n"
+ "LINE 8\n"
+ "LINE 9\n"
+ "LINE 10";
final String subst = "$1(\\$1)is for replace all text with nothing (remoove all text)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}