#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\bclsx\s*\(\s*{?[\"\']([_a-zA-Z0-9\s\-\:\/]+)[\"\'])|(?:\btw\\s*([_a-zA-Z0-9\s\-\:\/]*))"
Local $sString = "<div className="mx-auto sm:px-5 container"> hello </div>" & @CRLF & _
"" & @CRLF & _
"tw={"hello"}" & @CRLF & _
"" & @CRLF & _
"<div className={" & @CRLF & _
" (type === "fixed")" & @CRLF & _
" ? clsx(" flex flex-col px-12 mx-auto sm:px-5 container md:px-10 xl:px-24 container", className)" & @CRLF & _
" : clsx("container flex flex-col", className)" & @CRLF & _
" }>" & @CRLF & _
" {children} clsx({"hello"})" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")