# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:[!#].*)?\n)+"
test_str = ("\n\n"
"# catch this comment\n"
"!mycommand\n"
"# catch this comment\n"
"#catch this comment too\n"
"!mycommand\n\n"
"# catch this comment\n"
"!mycommand\n"
"!mycommand\n\n"
"some code. match until the previous line\n"
"# do not catch this comment\n"
"!mycommand\n"
"# do not catch this comment")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.