import Foundation
let pattern = #"\d{2}\.\d+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Добрый день.
Как сформировать регулярное приложение, чтобы из подобного массива можно было вытаскивать координаты.
[3] => 17629,17629,"ПОНТОННЫЙ, ВОКЗАЛ",59.785067,30.627792,0,2,bus
[4] => 17630,17630,ДОРОГА НА КОЛПИНО,59.775908,30.653787,0,2,bus
К примеру чтобы я получил массив
[0] => 59.785067
[1] => 30.627792
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)