const regex = /RafflesBotto(?:.|\n)*span\sclass="pl-2.?>x\s*([0-9]+)</gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('RafflesBotto(?:.|\\n)*span\\sclass="pl-2.?>x\\s*([0-9]+)<', 'gm')
const str = `<div class="RafflesBottomBackgroundWrapper d-flex justify-content-between"><div class="align-self-center"><img class="ml-4 my-3" src="https://assets.tophatter.com/assets/raffle/ticket_enabled-2c999ae451057b4f75762c500dc20ce0183176ab98068a5864a7c16d68bae720.png" width="24" height="16"><span class="pl-2">x 100</span></div><button type="button" class="btn btn-lg btn-primary mr-4 my-2 w-30"><span><span class="fa fa-star"></span><span class="ml-1">20</span></span></button></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}