import re
regex = re.compile(r"RafflesBotto(?:.|\n)*span\sclass=\"pl-2.?>x\s*([0-9]+)<", flags=re.MULTILINE)
test_str = "<div class=\"RafflesBottomBackgroundWrapper d-flex justify-content-between\"><div class=\"align-self-center\"><img class=\"ml-4 my-3\" src=\"https://assets.tophatter.com/assets/raffle/ticket_enabled-2c999ae451057b4f75762c500dc20ce0183176ab98068a5864a7c16d68bae720.png\" width=\"24\" height=\"16\"><span class=\"pl-2\">x 100</span></div><button type=\"button\" class=\"btn btn-lg btn-primary mr-4 my-2 w-30\"><span><span class=\"fa fa-star\"></span><span class=\"ml-1\">20</span></span></button></div>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")