re = /(?:\\.|[^*])*\*((?:\\.|[^*])*)\*/
str = '\\*jdjdjdfdf*test*dfsdf\\*adfasdasdasd*test**test\\**sd*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end