#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Begin:.*(?:\R(?!ModelFinish).*)*(?=\RSaving)"
Local $sString = "Begin: model 17" & @CRLF & _
"Epoch 15800, loss 4051304.017, val_PMAE 6.9" & @CRLF & _
"Saving at epoch 15828 with loss: 3974847.290" & @CRLF & _
"Saving at epoch 15889 with loss: 3968749.471" & @CRLF & _
"ModelFinish: Stop training" & @CRLF & _
"Begin: model 18" & @CRLF & _
"Saving at epoch 15889 with loss: 3968749.223" & @CRLF & _
"Saving at epoch 15889 with loss: 3968749.200" & @CRLF & _
"Epoch 15800, loss 4051304.017" & @CRLF & _
"ModelFinish: Stop training" & @CRLF & _
"Begin: model 19" & @CRLF & _
"Saving at epoch 15889 with loss: 3968749.223" & @CRLF & _
"Saving at epoch 15889 with loss: 3968749.200" & @CRLF & _
"Saving at epoch 15889 with loss: 3968749.200" & @CRLF & _
"Saving at epoch 15889 with loss: 3968749.200" & @CRLF & _
"Saving at epoch 15889 with loss: 3968749.200" & @CRLF & _
"Saving at epoch 15889 with loss: 3968749.200" & @CRLF & _
"Saving at epoch 15889 with loss: 3968749.200" & @CRLF & _
"Epoch 15800, loss 4051304.017" & @CRLF & _
"ModelFinish: Stop training"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")