$re = '/^[ \t]+|[ \t]+(?=\s)/m';
$str = ' Bla bla bla blabla bla
blabla
fdfg
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;