$re = '/[^\\\\]*\.(\w+)\s/m';
$str = 'Symchk result for D:\\pkgshadow\\19H1\\999907\\files.csi\\arm64\\neutral\\fre\\Microsoft-OneCore-VirtualizationBasedSecurity-Package~31bf3856ad364e35~amd64~~10.0.21380.1020.mum is NOTAPPLICABLE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);