package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bpossible\b`)
var str = `Impossible to do
I'm possible :)
possibler`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}