package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i).+\[?(.+?)\]?`)
var str = `Application key [base64:HlOiabVcCmzUvcnPuCHCOS6nvS89otzCBXKb/PVbI1g=] set successfully.
base64:zI1EaQeidtfpLwE9b8sGo5sZDbnzAqULCnL2hT3HoJo=`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}