// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i).+\[?(.+?)\]?").unwrap();
let string = "Application key [base64:HlOiabVcCmzUvcnPuCHCOS6nvS89otzCBXKb/PVbI1g=] set successfully.
base64:zI1EaQeidtfpLwE9b8sGo5sZDbnzAqULCnL2hT3HoJo=";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}