use strict;
my $str = '"datetime" === true. Para a minha expressão ficar correta eu preciso que ele encontre a partir de uma string de char inserida somente as palavras correspondentes a mesma, ou seja, para ser true no caso do "datetime" a palavra inserida precisaria ser "datetime-local';
my $regex = qr/\bdatetime-local\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}