re = /\bdatetime-local\b/m
str = '"datetime" === true. Para a minha expressão ficar correta eu preciso que ele encontre a partir de uma string de char inserida somente as palavras correspondentes a mesma, ou seja, para ser true no caso do "datetime" a palavra inserida precisaria ser "datetime-local'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end