Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(feature|fix|docs|style|refactor|test|build|ci|performance)(\()([A-Z0-9]{2,10}-{1}[0-9]{1,})(\)){1}\:\s(add|remove|create|update|change|prepare)\s(.{3,100})$|^(Merge branch)( \'release\/)([0-9]+\.)([0-9]+\.)([0-9]+)(\')$|^(Initial commit)$|^(Prepare next release)$|^(Close release )([0-9]+\.)([0-9]+\.)([0-9]+)$|^(Apply suggestion to )(.{3,100})$
/
gm
Input 1
1
New