const regex = /(https?:\/\/)?(www\.)?(discord\.gg|(discordapp|discord)\.com\/invite)\/(\w+-?\w+)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/)?(www\\.)?(discord\\.gg|(discordapp|discord)\\.com\\\/invite)\\\/(\\w+-?\\w+)', 'ig')
const str = `discord.gg/craftserve
discord.gg/craftserve-387222965131149313
discord.com/invite/craftserve
discord.com/invite/craftserve-387222965131149313
https://discord.gg/craftserve
https://discord.gg/craftserve-387222965131149313
https://discord.com/invite/craftserve
https://discord.com/invite/craftserve-387222965131149313
https://www.discord.gg/craftserve
https://www.discord.gg/craftserve-387222965131149313
https://www.discord.com/invite/craftserve
https://www.discord.com/invite/craftserve-387222965131149313`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}